Technical issues with ewp.live domain
Incident Report for EasyWP
Resolved
The incident has been resolved.
Posted May 28, 2022 - 18:15 UTC
Monitoring
The ewp.live domain and all its subdomains are operational again. We are monitoring the situation now.
Posted May 28, 2022 - 17:46 UTC
Identified
We are experiencing temporary technical issues with ewp.live domain. EasyWP websites with a ewp.live extension are not reachable right now.

We are working hard to resolve it in the shortest time.
Posted May 27, 2022 - 21:12 UTC
This incident affected: Customer sites.